Invoice delivery delayed due to Peppol downtime

Incident Report for Checkin

Resolved

Peppol’s downtime was resolved after ~2 hours. The paused invoices were then delivered by the preferred method.

If any invoices were delivered by email that should have been sent by Peppol, you can contact support@checkin.no for help.
Posted Aug 26, 2025 - 12:15 CEST

Monitoring

Due to downtime in the Peppol e-invoicing network, we are currently unable to:
• Send invoices to Peppol recipients
• Determine which recipients should receive invoices via Peppol vs. email

As a result, all invoice delivery is temporarily paused.

Once Peppol is back online, delivery will resume and invoices will be sent by the correct method based on the Peppol lookup.
Posted Aug 25, 2025 - 10:15 CEST
This incident affected: Payments (Invoicing).