The issue affecting participant refunds has now been resolved, and all pending refunds have been processed.
The issue affected refunds for card payments where the refund was initiated on or after February 26 for payments originally made before that date.
Please note that it may take a few days before the refunded amount appears on the participant’s card, depending on bank processing times.
We apologize for the inconvenience and appreciate your patience.
Posted Mar 05, 2026 - 13:01 CET
Update
We are continuing to investigate this issue.
Posted Mar 03, 2026 - 13:47 CET
Investigating
We are currently experiencing delays in processing participant refunds. Our team is actively investigating and working to resolve the issue. Refunds for affected orders will be processed as soon as the issue is resolved. We will provide an update once more information is available.
Posted Mar 03, 2026 - 13:39 CET
This incident affected: Payments (Visa/Mastercard, Vipps, Refunds).